nie działający przycisk Edytuj Projekt Kanban

Witajcie ponownie. 

Dopiero ucze się obsługi odoo dlatego proszę o wyrozumiałość. 

Mam taki dziwny przypadek, mianowicie, gdy wchodzę w projekty, chcąc edytować któryś klikam w otwierające się menu projektu (tam gdzie jest edytuj projekt, usuń  i zmiana koloru), nie działa mi przycisk edytuj projekt. mianowicie jest 0 reakcji.  podobnie też przycisk utwórz który znajduje się na górze.  Gdy zmienie widok na Gantta wszystko działa bez zarzutu. widok Kanban niestety nie. Czy ktoś z was sie spotkał z takim problemem ?  Przycisk utworzenia projektu dorobiłem sobie do menu, lecz nie o to chodzi by coś dorzucać a bardziej chciałbym się dowiedzieć jak naprawić ten problem.

Z góry dzięki za pomoc! 

 

Mateusz
Mateusz
6
| 2 1 1
Data pytania 02.07.2015, 08:53
0
głos
1323 Odsłony

własnie sprawdzałem to już i bez problemu JS nie wyrzuca żadnych błędów, nie było nic przerabiane. przycisk reaguje tak samo jak w wersji testowej odoo,  z tym ze w testowej otwiera okno edycji a tutaj nie chce. 

////EDIT/////

 

Gdy próbuje zaktualizować projekty wystakuje mi taki błąd :

 

Traceback (most recent call last): File "/opt/odoo/odoo/openerp/http.py", line 536, in _handle_exception return super(JsonRequest, self)._handle_exception(exception) File "/opt/odoo/odoo/openerp/http.py", line 573, in dispatch result = self._call_function(**self.params) File "/opt/odoo/odoo/openerp/http.py", line 309, in _call_function return checked_call(self.db, *args, **kwargs) File "/opt/odoo/odoo/openerp/service/model.py", line 113, in wrapper return f(dbname, *args, **kwargs) File "/opt/odoo/odoo/openerp/http.py", line 306, in checked_call return self.endpoint(*a, **kw) File "/opt/odoo/odoo/openerp/http.py", line 802, in __call__ return self.method(*args, **kw) File "/opt/odoo/odoo/openerp/http.py", line 402, in response_wrap response = f(*args, **kw) File "/opt/odoo/odoo/addons/web/controllers/main.py", line 948, in call_button action = self._call_kw(model, method, args, {}) File "/opt/odoo/odoo/addons/web/controllers/main.py", line 936, in _call_kw return getattr(request.registry.get(model), method)(request.cr, request.uid, *args, **kwargs) File "/opt/odoo/odoo/openerp/api.py", line 241, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/odoo/openerp/addons/base/module/module.py", line 537, in button_immediate_upgrade return self._button_immediate_function(cr, uid, ids, self.button_upgrade, context=context) File "/opt/odoo/odoo/openerp/api.py", line 241, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/odoo/openerp/addons/base/module/module.py", line 498, in _button_immediate_function registry = openerp.modules.registry.RegistryManager.new(cr.dbname, update_module=True) File "/opt/odoo/odoo/openerp/modules/registry.py", line 370, in new openerp.modules.load_modules(registry._db, force_demo, status, update_module) File "/opt/odoo/odoo/openerp/modules/loading.py", line 355, in load_modules loaded_modules, update_module) File "/opt/odoo/odoo/openerp/modules/loading.py", line 255, in load_marked_modules loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules, perform_checks=perform_checks) File "/opt/odoo/odoo/openerp/modules/loading.py", line 176, in load_module_graph _load_data(cr, module_name, idref, mode, kind='data') File "/opt/odoo/odoo/openerp/modules/loading.py", line 118, in _load_data tools.convert_file(cr, module_name, filename, idref, mode, noupdate, kind, report) File "/opt/odoo/odoo/openerp/tools/convert.py", line 895, in convert_file convert_csv_import(cr, module, pathname, fp.read(), idref, mode, noupdate) File "/opt/odoo/odoo/openerp/tools/convert.py", line 963, in convert_csv_import raise Exception(_('Module loading %s failed: file %s could not be processed:\n %s') % (module, fname, warning_msg)) Exception: Module loading hr_gamification failed: file hr_gamification/security/ir.model.access.csv could not be processed: Line 1 : Nie znaleziono rekordu odpowiadaj\u0105cego zewn\u0119trzny identyfikator 'base.group_hr_user' w polu 'Group'

 

 

Mateusz
Mateusz
6
| 2 1 1
Data odpowiedzi 02.07.2015, 09:05
0
głos

Podglądaj debuger javascriptu w momencie kliknięcia i zobacz jaka jest odpowiedz serwera na wywoływaną kliknięciem metodę. Włacz także log Odoo i tam zajrzyj.

Dariusz Żbikowski
na 02.07.2015, 09:13

Ps. sprawdz jeszcze uprawnienia do Projektów. Czy możesz edytować jak przęłaczysz kanban na listę i wybierzesz coś do edycji?

Dariusz Żbikowski
na 02.07.2015, 09:18

Właśnie w tym problem ze nie wiem dlaczego nie mam widoku listy. Jedyne widoki które mam to Kanban i Gantt.

Mateusz
na 02.07.2015, 09:21

Odinstalowuj zatem kolejno moduły nie autoryzowane i sprawdz, który z nich rozrabia. jelsi nie masz takich zrób update całości systemu.

Dariusz Żbikowski
na 02.07.2015, 09:23

zrobiłem tak jak mówiłeś, odinstalowałem praktycznie wszystkie moduły (nawet cześć tych podstawowych) niestety dalej nie odzyskałem widoku listy oraz nie działają przyciski. czy moduły odinstalowane ale znajdujące się w katalogu modułów mogą jakoś wpływać na pracę strony ?

Mateusz
na 02.07.2015, 09:40

Mogą wpływać jakieś pozostałości po nich. Najlepiej zrobic teraz generalne update. W usuwaniu pozostałości często pomocnym jest ten moduł https://www.odoo.com/apps/modules/8.0/database_cleanup/ ale .... aby go uzywać lepiej dokładnie wiedzieć co się robi!!!

Dariusz Żbikowski
na 02.07.2015, 10:03

Wszystko wskazuje na jakieś błędy związane z uprawnieniami. Zrób najpierw update całości a potem zobaczymy.

Dariusz Żbikowski
na 02.07.2015, 10:40

Update całości przez ustawienia wskazuje że wszystko jest aktualne

Mateusz
na 02.07.2015, 10:43

Aktualizacja listy modułów systemu to nie jest to samo (w zasadzie prawie nic nie robi), co jego aktualizacja faktyczna. Najlepiej ściagnąć ostatnie źródła i je wgrać. Potem w zależności od sytemu wykonać procedurę jego update. Dorażnie możesz spróbować znaleźć na liście modułów ten o nazwie "base" i kliknąc na jego aktualizację.

Dariusz Żbikowski
na 02.07.2015, 10:53

Dariusz Wielkie dzięki za pomoc! Po zaktualizowaniu Modułu "Base" Dosłownie wszystko powróciło na swoje miejsce! teraz działa to tak jak powinno działać. Wielkie dzięki jeszcze raz.

Mateusz
na 02.07.2015, 11:15

Na Darka zawsze możesz liczyć ... "Się zna chłopak" ; )

Dr.One
na 02.07.2015, 14:49

Przypuszczalnie jest jakiś kłopot z javascriptem. Czy był przerabiany?? Jeśli tak, to tu szukaj błędu. Włącz sobie najlepiej jakiś debuger javascriptu.

Dariusz Żbikowski
Dariusz Żbikowski
1263
| 4 3 3
Data odpowiedzi 02.07.2015, 09:02
0
głos

Twoja odpowiedź

Spróbuj dać znacząca odpowiedź. Jeśli chcesz wypowiedzieć się na temat pytania lub odpowiedzi, po prostu użyj narzędzia komentowania. Proszę pamiętać, że zawsze można zrewidować swoją odpowiedź - nie ma potrzeby odpowiadać na to samo pytanie dwa razy. Także prosimy, nie zapomnij zagłosować - to naprawdę pomaga wybrać najlepsze pytania i odpowiedzi!

Zadaj Pytanie

Bądź na bieżąco

O tym forum

Forum dla profesjonalistów i entuzjastów systemu Odoo. Dyskusje, porady, opinie, komentarze.

Przeczytaj wytyczne

Narzędzia do pytań

3 obserwujący

Statystyki

Spytał/a: 02.07.2015, 08:53
Oglądano: 1323 razy
Ostatnia aktualizacja: 02.07.2015, 10:24