Czy OpenERP współpracuje z PostgreSQL 9.2?

Na moim systemie Ubuntu, robiąc upgrade, doinstalowałem PostgreSQL w wersji 9.2. Obecnie mam zainstalowane obie wersje postgres-a, czyli 9.1 i 9.2. OpenERP wersja 7 odczytuje bez problemu bazę z wersji 9.1 jednak nie chce mi odczytać bazy utworzonej w wersji 9.2.

Czy OpenERP v 7 współpracuje z PostgreSQL 9.2?

Damian Zwarek
Damian Zwarek
1
| 1 1 1
Data pytania 12.09.2014, 08:23
0
głos
1210 Odsłony

Twój problem prawdopodobnie polega na tym, że każda z wersji postgresql pracuje na innym porcie.

W pliku /etc/postgresql/9.2/main/postgresql.conf znajdziesz numer portu na którym pracuje aktualnei Twoja wersja 9.2

z kolei w pliku konfiguracyjnym OpenERP    /etc/openerp/openerp-server.conf

odnajdziesz zmienną konfiguracyjną db_port = False, która określa na którym porcie openerp łaczy się z baza danych. Standardową wartością jest False, co opdpowiada portowi standardowemu postgresql.  Wstaw w to miejsce numer portu, który masz ustawiony dla postgresql 9.2 i system winien się połaczyć z nowymi bazami.

np.  db_port = 5433  

Niestety, nic mi nie wiadomo o tym aby OpenERP mógł jednocześnie łaczyć sie z róznymi wersjami postgresql na różnych portach

Janusz Stefaniak
Janusz Stefaniak
597
| 3 1 2
Data odpowiedzi 12.09.2014, 10:44
2
głos

Twoja odpowiedź

Spróbuj dać znacząca odpowiedź. Jeśli chcesz wypowiedzieć się na temat pytania lub odpowiedzi, po prostu użyj narzędzia komentowania. Proszę pamiętać, że zawsze można zrewidować swoją odpowiedź - nie ma potrzeby odpowiadać na to samo pytanie dwa razy. Także prosimy, nie zapomnij zagłosować - to naprawdę pomaga wybrać najlepsze pytania i odpowiedzi!

Zadaj Pytanie

Bądź na bieżąco

O tym forum

Forum dla profesjonalistów i entuzjastów systemu Odoo. Dyskusje, porady, opinie, komentarze.

Przeczytaj wytyczne

Narzędzia do pytań

2 obserwujący

Statystyki

Spytał/a: 12.09.2014, 08:23
Oglądano: 1210 razy
Ostatnia aktualizacja: 20.09.2014, 11:14