Baza firmowych dokumentów [Zamknięte]

To pytanie zostało zamknięte z powodu: niezwiązane z tematem lub nieaktualne

przez
Dr.One
na 19.04.2015 12:14:55

Chcę utworzyć bazę firmowych dokumentów.

W Systemie istnieje cos takiego jak "Knowledge" i Document management czy Document Management - Wiki - Work Instructions po zainstalowaniu pojawia się dodatkowe menu "Management system i Knowledge, jednak przy próbie otwarcia istniejącego obiektu "Work instructions" pojawia sie błąd:

 

Odoo

Odoo Server Error

Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 530, in _handle_exception return super(JsonRequest, self)._handle_exception(exception) File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 567, in dispatch result = self._call_function(**self.params) File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 303, in _call_function return checked_call(self.db, *args, **kwargs) File "/usr/lib/python2.7/dist-packages/openerp/service/model.py", line 113, in wrapper return f(dbname, *args, **kwargs) File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 300, in checked_call return self.endpoint(*a, **kw) File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 796, in __call__ return self.method(*args, **kw) File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 396, in response_wrap response = f(*args, **kw) File "/usr/lib/python2.7/dist-packages/openerp/addons/web/controllers/main.py", line 949, in call_kw return self._call_kw(model, method, args, kwargs) File "/usr/lib/python2.7/dist-packages/openerp/addons/web/controllers/main.py", line 932, in _call_kw records = getattr(request.session.model(model), method)(*args, **kwargs) File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 900, in proxy result = meth(cr, request.uid, *args, **kw) File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 241, in wrapper return old_api(self, *args, **kwargs) File "/usr/lib/python2.7/dist-packages/openerp/models.py", line 3125, in read result = BaseModel.read(records, fields, load=load) File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 239, in wrapper return new_api(self, *args, **kwargs) File "/usr/lib/python2.7/dist-packages/openerp/models.py", line 3168, in read values[name] = field.convert_to_read(record[name], use_name_get) File "/usr/lib/python2.7/dist-packages/openerp/models.py", line 5534, in __getitem__ return self._fields[key].__get__(self, type(self)) File "/usr/lib/python2.7/dist-packages/openerp/fields.py", line 765, in __get__ self.determine_value(record) File "/usr/lib/python2.7/dist-packages/openerp/fields.py", line 867, in determine_value self.compute_value(recs) File "/usr/lib/python2.7/dist-packages/openerp/fields.py", line 823, in compute_value self._compute_value(records) File "/usr/lib/python2.7/dist-packages/openerp/fields.py", line 815, in _compute_value self.compute(records) File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 239, in wrapper return new_api(self, *args, **kwargs) File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 546, in new_api result = method(self._model, cr, uid, self.ids, *args, **kwargs) TypeError: _get_display_content() takes at least 6 arguments (5 given)

I mówiąc szczerze, nie wiem gdzie szukać problemu. Jasno jednak wskazuje że ilość argumentów wymaganych jest .... 6

Poz zamknięciu pojawiają sie co prawda przyciski CREATE i IMPORT i po kliknięciu na CREATE otwiera się okno nowego dokumentu ale zapisać się nie da i też wyświetla błąd (ten sam jak wyżej)

Macie jakies pomysły jak to naprawić ?

Bardzo przydatne byłoby miec w systemie własnie taką bazę dokumentów.

Dr.One
Dr.One
341
| 5 3 5
Data pytania 05.03.2015, 13:08
0
głos
427 Odsłony

Może zrób upgrade obu modułów i zrestartuj system - gdzieś masz chyba błąd w systemie

Janusz Stefaniak
na 05.03.2015, 18:24

sprawdzę na domowym serwerze, jeśli będzie OK to znaczy, że faktycznie albo kolejność instalacji chociaż ... wszystkie zależne moduły są ładowane automatycznie :( Powinno więc działać.

Dr.One
na 05.03.2015, 20:33

Sukces, zainstalowałem MGM dla 8.0 i dopiero następnie resztę. działa :)

Dr.One
na 05.03.2015, 20:52

Twoja odpowiedź

Spróbuj dać znacząca odpowiedź. Jeśli chcesz wypowiedzieć się na temat pytania lub odpowiedzi, po prostu użyj narzędzia komentowania. Proszę pamiętać, że zawsze można zrewidować swoją odpowiedź - nie ma potrzeby odpowiadać na to samo pytanie dwa razy. Także prosimy, nie zapomnij zagłosować - to naprawdę pomaga wybrać najlepsze pytania i odpowiedzi!

Zadaj Pytanie

Bądź na bieżąco

O tym forum

Forum dla profesjonalistów i entuzjastów systemu Odoo. Dyskusje, porady, opinie, komentarze.

Przeczytaj wytyczne

Narzędzia do pytań

3 obserwujący

Statystyki

Spytał/a: 05.03.2015, 13:08
Oglądano: 427 razy
Ostatnia aktualizacja: 19.04.2015, 12:14